Inaccessible images


Bert Green
 

I've been rebuilding my old Freeway site in Xway from scratch, and it's going very well. With the ability to use Flexbox in extended mode I am able to create a site that will be as fully featured as my old Freeway site, although I still have to wait for features like Master pages, character styles, and upload. But for now I have good workarounds.

I have come upon a strange problem, however. I have been importing images into my pages with no problems until today, when I have found that some of the images I need are showing up as "inaccessible" after being imported into a box. Instead of the image, I get a grey box with a question mark.

I tried to create new folder and place the images in that folder, thinking it was a permissions issue, but the same thing happens.

When I created a template page I put placeholder images into a layout and when I create a new page I copy the template into a folder, then replace the placeholder images with the ones I need for that page. Although the path to the original template image is still intact, it also shows as inaccessible now as well.

Any ideas?


Bert Green
 

Update: I found that trying to locate the files using the content tab in the box inspector did not work, it would find the file and the path is correct, but the file remains inaccessible. This was true using the Resources panel as well.  However, when I restarted the computer (I'm using a 2014 MacBook Pro on Mojave), I was then able to locate and reset the status of the inaccessible files.

After working again for a short while, files would again begin to appear as inaccessible in the Resources panel, and again, after a restart, I was then again able to locate and reset the status to OK.

Only reason I'm still on Mojave is that I need to run Freeway until I can get this site up and running, then I can make the switch to Big Sur, and soon, to a new Mac (no looking back at that point!).


Jeremy Hughes
 
Edited

Hi Bert,

I've run Xway under Mojave to see if I can reproduce the problem you're having, but I haven't succeeded. If a file is inaccessible, it means that it exists where Xway expects to find it - but the system denies access for sandboxing reasons. Sandboxing is a way that the system protects files from being accessed without the user having given permission for this to happen. Typically, a user gives permission by selecting the file in a file dialog. A sandboxed application is allowed to access that file, and can also save a secure bookmark within a document, so that it is allowed to access the same file when the document is reopened. (Access permission also lasts until an application is quit, even if a secure bookmark has not been saved.)

If you can reproduce the problem you are having, and perhaps send me your document with some steps along the lines of "1. Locate this image. 2. Resave the document. 3. Quit and restart Xway. 4. Reopen the document. 5. >> The image is inaccessible." - I can see if that happens for me, under Mojave or Big Sur.

I also wonder if there is something that is peculiar to your system. Are the images on an internal or external drive? Do you have some form of anti-virus software scanning your drive? Do you have any third-party system extensions? Does the problem happen if you start your Mac in Safe Mode ( https://support.apple.com/en-gb/guide/mac-help/mh21245/mac )? Have you checked your drive using Disk Utility?

Jeremy


Bert Green
 

Hi Jeremy-

Thanks for the reply, and for trying to see if the problem is reproducible.

Here's what I've found since I last wrote: In rebuilding my site (which is finished now and will be uploaded later today), I had a few very long days working in Xway. Since this had happened before, I would periodically check the resources panel to see if anything had become inaccessible, and it only happened once, after I had been working uninterrupted for like 8 hours. I immediately restarted the computer and went back into the panel and re-located the files and then they were fine. Importing also worked correctly again after that restart.

So I am thinking this might be a problem with my computer, and for diagnostics, all files are all on the internal drive, anti-virus does not seem to interfere, I ran Disk Utility, but not try the Safe Mode option, but did not see it happen again except that one time after a long session. This laptop is an old beast, and once I finish this site revamp and one other that I did for a client, I will upgrade the OS to Big Sur and let you know if I see any other issue.

Also, as an FYI, when I have more time I will send you a few things I have discovered as I work that are probably not bugs, but behavior anomalies in text handling that you might be interested in knowing about (they are very minor). I have three projects on my plate right now so I'll get to that after I'm on Big Sur and I can be sure they are also not specific to my situation.

Bert


Bert Green
 

If anyone is interested, here is the link to my redesigned website built from scratch in Xway:

https://bgfa.us

It has dozens of pages and hundreds of images. It was a lot of work but I now can say that Xway is an excellent tool, extremely stable, and once you get the hang of it, actually quite intuitive.

Bert Green


Bert Green
 

Update: I moved past Mojave and updated to Big Sur and the problem with inaccessible images seems to have stopped, so I assume it was related to Mojave and my old laptop.

I'm working only in Xway now and have found that is very stable, and works great for my current needs. I'll look forward to the upload function and for master pages to be enabled, but for now Xway is performing very well.