flickering


Leo Cavanagh
 

When I preview my site on the browser and move the pointer near the top of the page, things flicker and rearrange themselves.  It happens on one page only.  The others are fine. What's going on?


Jeremy Hughes
 

Hi Leo,

Can you send me a cut-down document to look at (via support at softpress dot com)?

Jeremy


Leo Cavanagh
 

It’s on dropbox. “flickering problem”
-Leo

On Aug 23, 2021, at 3:33 AM, Jeremy Hughes <jeremy@...> wrote:

Hi Leo,

Can you send me a cut-down document to look at (via support at softpress dot com)?

Jeremy


Jeremy Hughes
 

Hi Leo,

The flickering is happening because you've set "float: right" as an extended Hover style property for item1 in the Dynamic Styles section of the Box Inspector. This has the effect of floating item1 to the right whenever you move the mouse over it (in a browser or in Xway's web view).

The simplest way to fix this is:

1. Select item1
2. Open the Dynamic Styles section of the Box Inspector (and choose "Hover" if it's not already selected in the Type popup)
3. Select the "Inherit Dynamic Style" checkbox

This will remove the extended property and undefine the hover style.

I also noticed that you have two "main" items: "main" and "main2". It's recommended that you don't have more than one Main item on a page, so you should change one of these to a different HTML type (maybe Div or Section). [See p43 of the b4 User Guide.]

Finally, I see that you've also set "main2" to have a "float: right" extended property. This is preventing the videos and audio files from playing. You can remove this as follows:

1. Select "main2" (or whatever it is called if you change its type)
2. Open the Extended Properties section of the Box Inspector
3. Select "float right"
4. Click on the remove (minus) button

Jeremy


Leo Cavanagh
 

That did the trick.  Thanks!