audio not playing


Leo Cavanagh
 

I am working on a page with about 10 audio files, all mp3's of about one minute duration.  All except two will play when I preview in Safari.  I made these samples all on the same day, and they seem to have all the same settings.  I have deleted and re-inserted the problem files, both from the "insert audio" icon and from the "insert" menu.  Suggestions?


Jeremy Hughes
 

Hi Leo,

It's hard to say without seeing the actual page. Can you upload it and share a link?

If you don't want to do this, can you put your Xway document on Dropbox (or similar) and send a Dropbox (etc.) link to support at softpress dot com? It doesn't have to be a full document - you could make a cut-down document with the following steps:

  1. Duplicate the document (choose Duplicate from the File menu in Xway)
  2. Rename the duplicated document (choose Save in the File menu and give it a different name, such as "MP3 Problem")
  3. Delete any pages that aren't needed in the duplicated document
  4. Save the cut-down document
  5. Compress (zip) the cut-down document (select it in the Finder and choose Compress from the File menu) before putting it on Dropbox (or similar)

You don't need to send the MP3 files (or other resource files) separately, because they should be included in Xway's document package.

Jeremy


Leo Cavanagh
 

Page uploaded to dropbox.


On Aug 20, 2021, at 1:43 AM, Jeremy Hughes <jeremy@...> wrote:

Hi Leo,

It's hard to say without seeing the actual page. Can you upload it and share a link?

If you don't want to do this, can you put your Xway document on Dropbox (or similar) and send a Dropbox (etc.) link to support at softpress dot com? It doesn't have to be a full document - you could make a cut-down document with the following steps:

  1. Duplicate the document (choose Duplicate from the File menu in Xway)
  2. Rename the duplicated document (choose Save in the File menu and give it a different name, such as "MP3 Problem")
  3. Delete any pages that aren't needed in the duplicated document
  4. Save the cut-down document
  5. Compress (zip) the cut-down document (select it in the Finder and choose Compress from the File menu) before putting it on Dropbox (or similar)

You don't need to send the MP3 files (or other resource files) separately, because they should be included in Xway's document package.

Jeremy



Jeremy Hughes
 
Edited

Hi Leo,

1. I notice that you have Controls (i.e. the Controls checkbox) turned off. This means that there are no controls for users to click in order to play or pause the audio. Select each audio box and turn Controls back on.

2. Somehow, the text "Solano Mama" is not inside a paragraph (if you put a cursor inside it, the Paragraph Inspector doesn't appear). I'm not sure how this has happened, and it's not the main problem, but see below for steps on how to fix this.

3. The main problem is that you have accidentally added a "float: left" extended property to the HTML box "item2". This is making it difficult to select or click on anything in a browser. Select "item2" in Xway and remove the "float: left" extended property. Generally, it's OK to float images, but you can get strange results if you try to float HTML boxes.

As for the "Solano Mama" text, what I would do is:

  1. Put a cursor in it
  2. Press down-arrow a few times
  3. Press Shift-left-arrow until you've selected everything from the end of the box to the start of "Solano Mama"
  4. Press Backspace (Delete)
  5. Press Backspace again, so the cursor appears after the audio box
  6. Retype "Solano Mama"

There's also an empty paragraph between "main" and "item2" which is putting some extra space between these boxes. If you want to remove this space, click between the boxes so you see a text cursor and press backspace.

Jeremy


Jeremy Hughes
 

One other thing: the Blue Midnight graphic (which is floated right) might look better if you drag it to a position after the first paragraph in "item2" (so it doesn't float across and into the following box.)

Jeremy


Leo Cavanagh
 

Thanks, Jeremy.  I was quite frustrated at having to learn this new program, but your support has been quick, clear, and accurate.  Problems solved.  Until the next time!
Leo

On Aug 20, 2021, at 8:56 AM, Jeremy Hughes <jeremy@...> wrote:

[Edited Message Follows]
[Reason: [Removed duplicate step 7]]

Hi Leo,

1. I notice that you have Controls (i.e. the Controls checkbox) turned off. This means that there are no controls for users to click in order to play or pause the audio. Select each audio box and turn Controls back on.

2. Somehow, the text "Solano Mama" is not inside a paragraph (if you put a cursor inside it, the Paragraph Inspector doesn't appear). I'm not sure how this has happened, and it's not the main problem, but see below for steps on how to fix this.

3. The main problem is that you have accidentally added a "float: left" extended property to the HTML box "item2". This is making it difficult to select or click on anything in a browser. Select "item2" in Xway and remove the "float: left" extended property. Generally, it's OK to float images, but you can get strange results if you try to float HTML boxes.

As for the "Solano Mama" text, what I would do is:

  1. Put a cursor in it
  2. Press down-arrow a few times
  3. Press Shift-left-arrow until you've selected everything from the end of the box to the start of "Solano Mama"
  4. Press Backspace (Delete)
  5. Press Backspace again, so the cursor appears after the audio box
  6. Retype "Solano Mama"

There's also an empty paragraph between "main" and "item2" which is putting some extra space between these boxes. If you want to remove this space, click between the boxes so you see a text cursor and press backspace.

Jeremy