adding boxes


Seth Rosenblum
 

Question: I have already inserted boxes within the 'Main' section of a page now I find need to add another box as the first box under 'Main'.... I can't seem to find a way to get the added box to be within the Main box if not added initially. I'm sure I'm missing something here.... on the attached screenshot I'm trying to get the box labeled 'shop-page' to nest inside the 'Main' box not after it. Thanks!!  


Jeremy Hughes
 

Hi Seth,

If you select "view-cart" and press the left arrow key (so there is a cursor before it), Insert Box will insert a box before "view-cart".

You can also drag boxes to a new position in the page view.

Jeremy


Walter Lee Davis
 

Interesting. I just tried doing what I would have done in Freeway -- dragging the box in the left-column "tree" so its source order was where it should be, and that had no effect. Selecting an item and using Insert Box put the item last in the list.

Walter

On May 24, 2021, at 9:42 AM, sethr via groups.io <sethr=me.com@groups.io> wrote:

Question: I have already inserted boxes within the 'Main' section of a page now I find need to add another box as the first box under 'Main'.... I can't seem to find a way to get the added box to be within the Main box if not added initially. I'm sure I'm missing something here.... on the attached screenshot I'm trying to get the box labeled 'shop-page' to nest inside the 'Main' box not after it. Thanks!! <Screen Shot 2021-05-24 at 6.40.46 AM.png>


Jeremy Hughes
 

Hi Walter,

We haven't implemented dragging boxes in the Site panel yet, but you can drag them in the Page view.

If you select a box (in the Site panel or on the page) Xway inserts after the box you selected. If you select multiple boxes, it inserts after the last box you selected.

Jeremy


Seth Rosenblum
 

Ahhh, that worked but only by clicking on the box itself to select it, when I clicked on the view-cart  in the site panel it still put the new box after main not in it.... anyway problem solved.. thanks again!


Jeremy Hughes
 

You need the focus to be in the Page view rather than the Site panel when pressing left-arrow (in the Site panel, left-arrow will close the selected item).

The way to tell where the focus is (Page or Site panel) is that the Site panel has focus when selections are highlighted in blue rather than grey.

Jeremy