Date   

Mailing List Migrated

Simon Manning
 

This mailing list has been migrated, you can find the direct replacement here:
https://discourse.softpress.com/c/xway/16
 
More information about the migration can be found here:


Re: Migrating to Discourse

Crawford Hart
 

Discourse tell me an account is required and needs an invitation from an existing member. 


Re: graphic positioning

Jeremy Hughes
 

Hi Leo,

If the box doesn't have a specified height, its height is determined by its content. On reason there could be a difference between Xway's view and the browser view would be if you have added an extended (float: right) property to the graphic of the guitar neck. Xway outputs extended properties, but it doesn't interpret them when displaying a box (as it would do if it supported the property directly). According to CSS rules, floated items do not contribute to the content height of a box, so the browser disregards this (floated) image when calculating the box height.

If you want a box to have a minimum height when it is displayed in a browser, you can specify that by selecting the box and entering a minimum height in the Min/Max Dimensions section of the Box Inspector.

However, I'm partly guessing here - because I can only see screenshots of what the page looks like in Xway and in a browser, and I don't know what settings you have used for the various items. It might be easier to see what is happening if you can upload your page so I can view it in a browser. One way to do this without overwriting your existing site is to create a temporary online folder (you could call it "Test" or "0Test" or something) and upload to that.

I took a look at your earlier version of this document, and one thing I noticed is that you sometimes use multiple space characters to position items: e.g. before and after the guitar neck graphic. Xway currently allows you to do this (as does Freeway), but it's not a good idea because multiple spaces are almost always collapsed to a single space within browsers. If you want to add space before/after images, you can do this by adding left/right margins.

Jeremy


graphic positioning

Leo Cavanagh
 

At the top of a page in xway, I have an item with a background image from a painting, some text, and a graphic of a guitar neck.  The painting comes out much smaller when I preview it in a browser.  How do I get it to be larger, like it appears in xway?  The guitar neck can be smaller, it doesn't need to match.


Re: Page not refreshing

erbril@cameleonpaint.com
 

You might want to empty the cache of your browser. My experience with chrome is also this slow. If you would check in a different browser you might see your positive result
Greetings 
Eugenie 

Cameleon bv


♻️ is what we believe 



This e-mail may contain confidential and/or privileged information.

If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and delete this e-mail. 

Any unauthorized copying, disclosure or distribution of the contents in this e-mail is strictly forbidden.



Op 25 aug. 2021 om 17:30 heeft Geoff Mullett <geoff10a@...> het volgende geschreven:

I have a page on my website http://www.louthjazzclub.org.uk/gallery.html that contains rows of thumbnails in png format that each have a link to a separate gallery page. This morning, I added a new thumbnail and associated links, saved everything then previewed it in Xway. Everything fine. I published, then uploaded from the site folder, but when viewing in Chrome (and Firefox and Safari), I was presented with the original gallery page without the update.
I've re-saved and re-published several times, I've duplicated the image and uploaded the page again, I've duplicated the page and uploaded both (gallery.html and gallery2.html), I've restarted the Mac, I've deleted the gallery page from the FTP list forcing a new one to upload. Nothing!
I've run out of ideas, any thoughts? Screenshot of the Xway preview page attached so you can see what should be there.
Geoff
<Screenshot 2021-08-25 at 16.12.03.png>


Re: Page not refreshing

Jeremy Hughes
 

Hi Geoff,

Are you sure that the page is being uploaded to the correct location?

It seems from your screenshot that you've added a new gallery (Worth Valley Hot 7) but it's not showing up.

The other possibility is that there is some kind of ISP caching which is delaying the updated page from appearing. It can't be a browser caching issue because I see the old version in my browser.

Jeremy


Page not refreshing

Geoff Mullett
 

I have a page on my website http://www.louthjazzclub.org.uk/gallery.html that contains rows of thumbnails in png format that each have a link to a separate gallery page. This morning, I added a new thumbnail and associated links, saved everything then previewed it in Xway. Everything fine. I published, then uploaded from the site folder, but when viewing in Chrome (and Firefox and Safari), I was presented with the original gallery page without the update.
I've re-saved and re-published several times, I've duplicated the image and uploaded the page again, I've duplicated the page and uploaded both (gallery.html and gallery2.html), I've restarted the Mac, I've deleted the gallery page from the FTP list forcing a new one to upload. Nothing!
I've run out of ideas, any thoughts? Screenshot of the Xway preview page attached so you can see what should be there.
Geoff


Re: spacing within items

Jeremy Hughes
 

1. You can use "float: left" or "float: right" on any images that you want text to wrap around (as you have been doing), but it's a good idea to avoid setting this on other types of boxes because that can cause problems (as you've seen).

2. You can control the spacing between paragraphs by changing the top and/or bottom margin to zero (in the Paragraph Inspector). There are some steps and explanations for how to do this in the Xway tutorial.

3. If you want to break lines so that there isn't a paragraph space between them - so they actually belong to the same paragraph - you can insert a line break (e.g. choose Line Break from the Insert menu or use the shortcut, Control-Return).

4. In future, Xway will add support for different kinds of automatic lists (numbered, bulleted etc.)


spacing within items

Leo Cavanagh
 

Can you give some general guidance on placing text and photos within an item?  I want to have some paragraphs and photos, and it seems the photos always create a big space between the lines of text.  Is there some type of "wrap" feature? Also, I would like to have some bullet points, but every time I hit return it makes the text look double-spaced.  How do I get lines closer together?
Thanks.


Re: flickering

Leo Cavanagh
 

That did the trick.  Thanks!


Re: Migrating to Discourse

Simon Manning
 

Hi All,
 
We will be starting the migration to Discourse soon. First we will be suspending access to Discourse while we run a task that will deal with some posts having their content trimmed, followed by a second task that will ensure this additional content does not expose email addresses in the posts.
 
These tasks will take approximately 2-3 hours to complete, at which point we will lock FreewayTalk and Groups io from receiving any further posts.
 
After this we will import the latest posts into Discourse, run a final task to ensure those new posts do not expose email addresses and finally reopen access to Discourse. This shouldn't take longer than 30 minutes, likely less.
 
Simon


Re: flickering

Jeremy Hughes
 

Hi Leo,

The flickering is happening because you've set "float: right" as an extended Hover style property for item1 in the Dynamic Styles section of the Box Inspector. This has the effect of floating item1 to the right whenever you move the mouse over it (in a browser or in Xway's web view).

The simplest way to fix this is:

1. Select item1
2. Open the Dynamic Styles section of the Box Inspector (and choose "Hover" if it's not already selected in the Type popup)
3. Select the "Inherit Dynamic Style" checkbox

This will remove the extended property and undefine the hover style.

I also noticed that you have two "main" items: "main" and "main2". It's recommended that you don't have more than one Main item on a page, so you should change one of these to a different HTML type (maybe Div or Section). [See p43 of the b4 User Guide.]

Finally, I see that you've also set "main2" to have a "float: right" extended property. This is preventing the videos and audio files from playing. You can remove this as follows:

1. Select "main2" (or whatever it is called if you change its type)
2. Open the Extended Properties section of the Box Inspector
3. Select "float right"
4. Click on the remove (minus) button

Jeremy


Re: flickering

Leo Cavanagh
 

It’s on dropbox. “flickering problem”
-Leo

On Aug 23, 2021, at 3:33 AM, Jeremy Hughes <jeremy@...> wrote:

Hi Leo,

Can you send me a cut-down document to look at (via support at softpress dot com)?

Jeremy


Re: flickering

Jeremy Hughes
 

Hi Leo,

Can you send me a cut-down document to look at (via support at softpress dot com)?

Jeremy


flickering

Leo Cavanagh
 

When I preview my site on the browser and move the pointer near the top of the page, things flicker and rearrange themselves.  It happens on one page only.  The others are fine. What's going on?


Re: Migrating to Discourse

Simon Manning
 

Hi Grant,

You can sign up on Discourse using your latest address and send me a message on this page:

Doesn't need to say much, it's just so I have a quick reference to the account you create. After I finish the migration next week, I'll merge the accounts for you so all the posts will fall under the one you create.

Simon

On Fri, 20 Aug 2021 at 16:29, grantsymon <xwayToo@...> wrote:
Hi Simon,

this looks like a good idea!  😊

I'm a little uncertain how to transition.  My email addresses are different for FW and XWay.   FW is fwtalk@... (it wasn't always this address.. was changed a few years back during my spam fight... which I've won 😎).   XWay is   xwayToo@...  but until not that long ago, it was  xway@....   I changed it after I started receiving spam on it.

Can only 1 address be used, or can they be combined in some way?

Regards,

Grant



On 20 Aug 2021, at 01:52, Simon Manning <simon.manning@...> wrote:

Hi All,
 
You might see this multiple times if you subscribe to multiple lists but they all say the same, you can safely ignore the duplicates.
  
Next week we will be migrating our community mailing lists into Discourse. That is all the lists on FreewayTalk and Groups io.
 
You can find more information about this here:
 
At this time posting is disabled in the imported categories to avoid splitting discussions, however you can sign up for an account and reply to the above topic or create new topics in the Site Feedback category if you have any comments on the migration or Discourse in general.
 
If you have made posts on the existing mailing lists, please read the Existing Posts and Profile sections of the topic linked above before signing up.
 
Shortly before starting the final steps of the migration, which we expect to be early afternoon on Tuesday UK time, we will send another notice to say this is happening. After this second notice we will close the existing FreewayTalk and Groups io lists, bring Discourse up to date with the latest posts and then open the imported categories to posting.
 
All of our links to the mailing lists, including those accessed via the Help menu in our apps, will be updated on our website to point at Discourse.
 
Simon


Re: audio not playing

Leo Cavanagh
 

Thanks, Jeremy.  I was quite frustrated at having to learn this new program, but your support has been quick, clear, and accurate.  Problems solved.  Until the next time!
Leo

On Aug 20, 2021, at 8:56 AM, Jeremy Hughes <jeremy@...> wrote:

[Edited Message Follows]
[Reason: [Removed duplicate step 7]]

Hi Leo,

1. I notice that you have Controls (i.e. the Controls checkbox) turned off. This means that there are no controls for users to click in order to play or pause the audio. Select each audio box and turn Controls back on.

2. Somehow, the text "Solano Mama" is not inside a paragraph (if you put a cursor inside it, the Paragraph Inspector doesn't appear). I'm not sure how this has happened, and it's not the main problem, but see below for steps on how to fix this.

3. The main problem is that you have accidentally added a "float: left" extended property to the HTML box "item2". This is making it difficult to select or click on anything in a browser. Select "item2" in Xway and remove the "float: left" extended property. Generally, it's OK to float images, but you can get strange results if you try to float HTML boxes.

As for the "Solano Mama" text, what I would do is:

  1. Put a cursor in it
  2. Press down-arrow a few times
  3. Press Shift-left-arrow until you've selected everything from the end of the box to the start of "Solano Mama"
  4. Press Backspace (Delete)
  5. Press Backspace again, so the cursor appears after the audio box
  6. Retype "Solano Mama"

There's also an empty paragraph between "main" and "item2" which is putting some extra space between these boxes. If you want to remove this space, click between the boxes so you see a text cursor and press backspace.

Jeremy



Re: audio not playing

Jeremy Hughes
 

One other thing: the Blue Midnight graphic (which is floated right) might look better if you drag it to a position after the first paragraph in "item2" (so it doesn't float across and into the following box.)

Jeremy


Re: audio not playing

Jeremy Hughes
 
Edited

Hi Leo,

1. I notice that you have Controls (i.e. the Controls checkbox) turned off. This means that there are no controls for users to click in order to play or pause the audio. Select each audio box and turn Controls back on.

2. Somehow, the text "Solano Mama" is not inside a paragraph (if you put a cursor inside it, the Paragraph Inspector doesn't appear). I'm not sure how this has happened, and it's not the main problem, but see below for steps on how to fix this.

3. The main problem is that you have accidentally added a "float: left" extended property to the HTML box "item2". This is making it difficult to select or click on anything in a browser. Select "item2" in Xway and remove the "float: left" extended property. Generally, it's OK to float images, but you can get strange results if you try to float HTML boxes.

As for the "Solano Mama" text, what I would do is:

  1. Put a cursor in it
  2. Press down-arrow a few times
  3. Press Shift-left-arrow until you've selected everything from the end of the box to the start of "Solano Mama"
  4. Press Backspace (Delete)
  5. Press Backspace again, so the cursor appears after the audio box
  6. Retype "Solano Mama"

There's also an empty paragraph between "main" and "item2" which is putting some extra space between these boxes. If you want to remove this space, click between the boxes so you see a text cursor and press backspace.

Jeremy


Re: Migrating to Discourse

grantsymon
 

Hi Simon,

this looks like a good idea!  😊

I'm a little uncertain how to transition.  My email addresses are different for FW and XWay.   FW is fwtalk@... (it wasn't always this address.. was changed a few years back during my spam fight... which I've won 😎).   XWay is   xwayToo@...  but until not that long ago, it was  xway@....   I changed it after I started receiving spam on it.

Can only 1 address be used, or can they be combined in some way?

Regards,

Grant



On 20 Aug 2021, at 01:52, Simon Manning <simon.manning@...> wrote:

Hi All,
 
You might see this multiple times if you subscribe to multiple lists but they all say the same, you can safely ignore the duplicates.
  
Next week we will be migrating our community mailing lists into Discourse. That is all the lists on FreewayTalk and Groups io.
 
You can find more information about this here:
 
At this time posting is disabled in the imported categories to avoid splitting discussions, however you can sign up for an account and reply to the above topic or create new topics in the Site Feedback category if you have any comments on the migration or Discourse in general.
 
If you have made posts on the existing mailing lists, please read the Existing Posts and Profile sections of the topic linked above before signing up.
 
Shortly before starting the final steps of the migration, which we expect to be early afternoon on Tuesday UK time, we will send another notice to say this is happening. After this second notice we will close the existing FreewayTalk and Groups io lists, bring Discourse up to date with the latest posts and then open the imported categories to posting.
 
All of our links to the mailing lists, including those accessed via the Help menu in our apps, will be updated on our website to point at Discourse.
 
Simon

1 - 20 of 971